Skip to main content

Site Requirements

Browser Requirements

For Windows users, the latest version of Microsoft® Internet Explorer, Firefox, or Chrome is recommended. For Mac users the latest version of Firefox is recommended. Other browsers may or may not be fully functional with the degree audit website depending on the browser and version and results may vary. For users of Google Chrome, in order to view the PDF audits disable the Chrome PDF viewer and enable the Adobe PDF viewer in your plugins. For your security, Degree Audit System requires a browser with a set of minimum capabilities such as support for 128-bit SSL encryption, JavaScript, and Cookies. If you do not have Internet Explorer, Chrome, or Firefox, you may download a copy using the links below.

Microsoft Internet Explorer

Firefox

Chrome